Log in
Bridge to 10K
6,791 members7,599 posts

Garmin Tech Question

Absolutely love my new Garmin Forerunner 35 but for some reason it's giving me my pace at the mile markers instead of km. I've googled it but it's not telling me anything I don't already know! I've got it set up to use kms and it's giving me all my stats on the app correctly but the watch is wrong.

Any ideas?

27 Replies
oldestnewest

Hmmm...just been fiddling with my watch and can’t see where they can be changed. Think it’s only on Garmin Connect app? Sorry - not much help. x

Reply

Just found Units on the watch and it's definitely set to kms - so is the app?? There's a couple of Garmin forum posts with people having similar problems so maybe it's a bug?x

1 like
Reply

Oh...I don’t like seeing miles on the app but can’t seem to change that to KM. x

Reply

It's in Settings - User Settings - scroll down to Unit of Measure x

Reply

Perfect! Thankyou! x

1 like
Reply

Try activity settings on the watch itself and then Laps. If that’s set to miles it might be it. Not sure though. I remember seeing a setting but can’t find it now 😞

Reply

Thanks - I've gone into Laps and it say it's set to Auto Lap 1km. I've turned it off and on again in the hope it might work! x

Reply

Don't you have a syllabus to learn?... C'mon... Off with you.... :-)

Reply

Not til this afternoon - Clarinet practise for the next hour :-)

Reply

Eww. Stick with the Garmin. Fewer squeaks and springs.... :-)

Reply

Oi! I've obviously not practised hard enough today - It's been logging practise as moderate exercise up to now but I think I might have been rumbled 😂

Reply

I've nothing super constructive to add, but I had this issue at first too—there seem to be several places you need to switch the units to get it consistently measuring in km. I wish I could be helpful enough to remember where those menus all were! But if it still has mixed units then check through the watch and Garmin connect to make sure you've not missed a sneaky 'miles' setting, there were more in there than I expected.

Reply

Thanks I'll keep looking - there are so many sub menus!x

Reply

Hope you get it sorted. Enjoy your music practice too.

Reply

Thanks x

Reply

If you manage to get it sorted please post the details. I’m also struggling with this

Reply

Will do! I've fiddled with every menu on the watch and can't see anything that would be causing it. I'm going out for a walk later so I'll see what it does then x

Reply

It's miraculously working now?!? If I knew why I'd tell you! One thing I did do was go into the watch menu and changed it to miles and then back to km - maybe I confused it into working :-)

Reply

Thx for that. Will try it today. Hopefully I’ll confuse mine too!

1 like
Reply

I bought a forerunner 35 about three months ago, and had the same problem. Kept on trying different things then one day it just changed to Kms. No idea why. Luckily it has continued in metric! Good luck.

Reply

Just been for a walk and it's fine now?!? :-)

Reply

Have you tried syncing it lately? Maybe some of these changes need to sync with the garmin cloud to take effect?

Reply

Thanks - working now x

Reply

Found a forum elsewhere suggesting the following for a different Garmin watch. It may help:

Managed to find a solution. I'd set the units to metric and the autolap "on" in the app. On the device itself, I set the units back to Imperial, turned autolap off then back on again, then set the units back to metric.

Autolap distance is now 1km. Whether it is the order of setting autolap on and setting to metric in the app, or whether you have to do it on the device to actually get it to force the change.... I have no idea. But at least for others with the same problem there is some information to help.

Reply

Excellent find! That's sounds pretty much like what I think I did - I was just a bit more random about it :-) My boyfriend is in IT and he thought it was some kind of bug so I suspect the order you do things in is probably part of the problem x

Reply

Can you believe it?!? I changed back to miles then back to K’s and it’s worked! Hurrah!!

Reply

Brilliant! I'm glad you've got it working x

Reply

You may also like...